DataHub classification
ID datahub
catalogs
DataHub can classify table columns during ingestion and attach a glossary term for each detected info type. The built-in classifier comes from the acryl-datahub-classify library: it scores a column by its name, description, data type and sample values, using regular expressions, spaCy named entities or the schwifty library. Its default configuration in reference_input.py defines 14 info types, such as Email_Address, IBAN, Swift_Code and US_Social_Security_Number. Recent acryl-datahub releases no longer include this built-in classifier.
- Website
- https://github.com/acryldata/datahub-classify/blob/main/datahub-classify/src/datahub_classify/reference_input.py
- Supported types
- 15
Supported semantic types
| ID | Name | Categories | Countries | Description |
|---|---|---|---|---|
| address | Address (physical location) PII | common, pii, geo | global | Geographic address, commonly consist of postindex, country, area, town, street and building |
| age | Age PII draft | datetime | global | Age of the person or organization in years |
| bankcard | Bank card (credit/debit card) PII | pii, finances | global | A bank card is typically a plastic card issued by a bank to its clients that performs one or more of a number of services that relate to... |
| bic | SWIFT/BIC code draft | finances | global | Datatype for 'SWIFT/BIC code' (bic) from rules in context 'finances'. |
| Email address PII | common, internet, pii | global | Address of an electronic mailbox in the form local-part@domain, defined in section 3.4.1 of RFC 5322. The local part names the mailbox,... | |
| gender | Gender PII draft | pii, persons | global | Gender flag and/or any other identification value |
| iban | International Bank Account Number | finances | global | The International Bank Account Number (IBAN) is an internationally agreed system of identifying bank accounts across national borders to... |
| ipv4 | IPv4 address PII | internet, pii | global | 32-bit address of Internet Protocol version 4 (RFC 791), written in dotted-decimal notation as four numbers from 0 to 255, such as... |
| ipv6 | IPv6 address PII | internet, pii | global | 128-bit address of Internet Protocol version 6, written as eight groups of up to four hexadecimal digits separated by colons (RFC 4291,... |
| person_fullname | Person fullname PII draft | persons, pii | global | Full name of the person as combination of last, first, and sometimes middle name |
| phone | Phone number PII | pii, common, telecom | global | Telephone number in standard format (RFC3966), without 'tel:' prefix |
| swiftcode | Bank SWIFT code (ISO 9362) | finances | global | ISO 9362 defines a standard format of Business Identifier Codes (also known as SWIFT-BIC, BIC, SWIFT ID or SWIFT code) approved by the... |
| usdriverlic | US driver license number PII | pii, persons | US | Alphanumeric value of the United States driver license |
| usssn | US Social Security Number PII | pii, persons | US | In the United States, a Social Security number (SSN) is a nine-digit number issued to U.S. citizens, permanent residents, and temporary... |
| vin | Vehicle Identification Number by field name draft | transport | global | Vehicle Identification Number by field name number |
Use this record
- JSON: API v1 · legacy shape
- Improve it: edit
data/tools/catalogs/datahub.yamlon GitHub