Tools

Soda

ID soda

other

Soda allows everyone on your data team to find, analyze, and resolve data issues. Our open-source tools and data observability platform bring everyone closer to the data, resulting in data products that you can trust.

Website
https://docs.soda.io/soda-sql/sql_metrics.html#valid-format-values
Supported types
8

Supported semantic types

IDNameCategoriesCountriesDescription
date Date datetime global Calendar date. The regexp covers the ISO 8601 extended form YYYY-MM-DD; other notations, such as DD.MM.YYYY, are patterns of this datatype.
email Email address PII common, internet, pii global Address of an electronic mailbox in the form local-part@domain, defined in section 3.4.1 of RFC 5322. The local part names the mailbox,...
ipv4 IPv4 address PII internet, pii global 32-bit address of Internet Protocol version 4 (RFC 791), written in dotted-decimal notation as four numbers from 0 to 255, such as...
ipv6 IPv6 address PII internet, pii global 128-bit address of Internet Protocol version 6, written as eight groups of up to four hexadecimal digits separated by colons (RFC 4291,...
ipaddr IP address (IPv4 or IPv6) PII internet, pii global Address of a network interface in the Internet Protocol: a 32-bit IPv4 address in dotted-decimal form (192.0.2.1) or a 128-bit IPv6...
time Time draft datetime global Time of the day, like 12:00 or 10PM or 11:05 or 18:01:27
phone Phone number PII pii, common, telecom global Telephone number in standard format (RFC3966), without 'tel:' prefix
uuid Universally unique identifier (UUID) identifiers global 128-bit identifier that systems generate without a central registry, defined by RFC 9562 (2024), which replaced RFC 4122. Microsoft...

Use this record