Metadata Guardian
ID metadata-guardian
pii
Metadata Guardian is a Python package that provides an easy way to protect your data sources by searching its metadata. By searching with data rules, it will detect what you are looking to protect. Using Rust, it makes blazing fast multi-regex matching.
- Website
- https://github.com/fvaleye/metadata-guardian
- Supported types
- 15
Supported semantic types
| ID | Name | Categories | Countries | Description |
|---|---|---|---|---|
| Email address PII | common, internet, pii | global | Address of an electronic mailbox in the form local-part@domain, defined in section 3.4.1 of RFC 5322. The local part names the mailbox,... | |
| phone | Phone number PII | pii, common, telecom | global | Telephone number in standard format (RFC3966), without 'tel:' prefix |
| ipv4 | IPv4 address PII | internet, pii | global | 32-bit address of Internet Protocol version 4 (RFC 791), written in dotted-decimal notation as four numbers from 0 to 255, such as... |
| ipv6 | IPv6 address PII | internet, pii | global | 128-bit address of Internet Protocol version 6, written as eight groups of up to four hexadecimal digits separated by colons (RFC 4291,... |
| ipaddr | IP address (IPv4 or IPv6) PII | internet, pii | global | Address of a network interface in the Internet Protocol: a 32-bit IPv4 address in dotted-decimal form (192.0.2.1) or a 128-bit IPv6... |
| postindex | Postal code/index PII | geo, pii, common | global | Postal index/code, unique post identifier used in address |
| address | Address (physical location) PII | common, pii, geo | global | Geographic address, commonly consist of postindex, country, area, town, street and building |
| person_firstname | Person firstname PII | persons, pii | global | First name of the person. For example, Donald or Vladimir or Jack |
| person_surname | Person surname/lastname PII | persons, pii | global | Last name of the person. For example, Smith or Ivanova |
| person_fullname | Person fullname PII draft | persons, pii | global | Full name of the person as combination of last, first, and sometimes middle name |
| birthday | Birthday PII | pii, datetime | global | A birthday is the anniversary of the birth of a person, or figuratively of an institution. Birthdays of people are celebrated in... |
| gender | Gender PII draft | pii, persons | global | Gender flag and/or any other identification value |
| nationality | Person nationality PII draft | pii, persons | global | Nationality of the person from list of unique code from one of code lists or defined somehow else. |
| username | Username PII draft | pii, persons | global | Name of the user or login, commonly used for authentication or user identification purposes |
| password | Password PII draft | common, pii | global | Passwords, usually associated with login/username/email. |
Use this record
- JSON: API v1 · legacy shape
- Improve it: edit
data/tools/pii/metadata-guardian.yamlon GitHub