RedGate SQL Data catalog
ID sqldatacatalog
catalogs
SQL Data Catalog helps you protect your business by providing a scalable and repeatable process for managing personally-identifiable information (PII), as it moves through your SQL Server estate. Our solution lets you create a data catalog of your SQL Server estate, and monitors and controls it for protection appropriate to the sensitivity of the data, ensuring compliance during data handling.
- Website
- https://documentation.red-gate.com/sql-data-catalog/data-scanning
- Supported types
- 20
Supported semantic types
| ID | Name | Categories | Countries | Description |
|---|---|---|---|---|
| bankaccount | Bank account | finances | global | A bank account is a financial account maintained by a bank or other financial institution in which the financial transactions between... |
| bankcard | Bank card (credit/debit card) PII | pii, finances | global | A bank card is typically a plastic card issued by a bank to its clients that performs one or more of a number of services that relate to... |
| Email address PII | common, internet, pii | global | Address of an electronic mailbox in the form local-part@domain, defined in section 3.4.1 of RFC 5322. The local part names the mailbox,... | |
| city | City PII | geo, pii, common | global | A city is a large human settlement. It can be defined as a permanent and densely settled place with administratively defined boundaries... |
| uscounty | US County draft | geo | US | Name or code of US County |
| ipv4 | IPv4 address PII | internet, pii | global | 32-bit address of Internet Protocol version 4 (RFC 791), written in dotted-decimal notation as four numbers from 0 to 255, such as... |
| ipv6 | IPv6 address PII | internet, pii | global | 128-bit address of Internet Protocol version 6, written as eight groups of up to four hexadecimal digits separated by colons (RFC 4291,... |
| person_surname | Person surname/lastname PII | persons, pii | global | Last name of the person. For example, Smith or Ivanova |
| person_firstname | Person firstname PII | persons, pii | global | First name of the person. For example, Donald or Vladimir or Jack |
| person_fullname | Person fullname PII draft | persons, pii | global | Full name of the person as combination of last, first, and sometimes middle name |
| gender | Gender PII draft | pii, persons | global | Gender flag and/or any other identification value |
| nationality | Person nationality PII draft | pii, persons | global | Nationality of the person from list of unique code from one of code lists or defined somehow else. |
| ipaddr | IP address (IPv4 or IPv6) PII | internet, pii | global | Address of a network interface in the Internet Protocol: a 32-bit IPv4 address in dotted-decimal form (192.0.2.1) or a 128-bit IPv6... |
| orgname | Company or organization name | companies | global | Name of the organization/business/company in any language |
| usssn | US Social Security Number PII | pii, persons | US | In the United States, a Social Security number (SSN) is a nine-digit number issued to U.S. citizens, permanent residents, and temporary... |
| phone | Phone number PII | pii, common, telecom | global | Telephone number in standard format (RFC3966), without 'tel:' prefix |
| url | Uniform Resource Locator (URL) | common, internet | global | Address of a resource on a network that also says how to retrieve it: a scheme such as https, a host, an optional port, a path, a query... |
| usstate | US State draft | geo | US | Name or code of US State |
| postindex | Postal code/index PII | geo, pii, common | global | Postal index/code, unique post identifier used in address |
| jobtitle | Work position / Job title | persons, companies | global | Work positions / job title |
Use this record
- JSON: API v1 · legacy shape
- Improve it: edit
data/tools/catalogs/sqldatacatalog.yamlon GitHub